What’s Vulnerable › Vulnerabilities
CVE-2024-3999: EazyDocs < 2.5.0 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The EazyDocs WordPress plugin before 2.5.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- EazyDocs: before 2.5.0 — fixed in 2.5.0
How to fix
Upgrade to a fixed version: EazyDocs 2.5.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6a8a1deb-6836-40f1-856b-7b3e4ba867d6/
- https://wpscan.com/vulnerability/6a8a1deb-6836-40f1-856b-7b3e4ba867d6/
Get alerted when CVE-2024-3999 or the next vulnerability affects your stack