What’s Vulnerable › Vulnerabilities
CVE-2024-4001: Download Manager <= 3.2.93 - Authenticated (Contributor+) Stored Cross-Site Scripting via wpdm_modal_login_form Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The Download Manager plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'wpdm_modal_login_form' shortcode in all versions up to, and including, 3.2.93 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Wpdownloadmanager Download Manager: before 3.2.94 — fixed in 3.2.94
How to fix
Upgrade to a fixed version: Wpdownloadmanager Download Manager 3.2.94. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3096459/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b478d88d-1423-4a33-b8ef-08b9e66a5d98?source=cve
- https://plugins.trac.wordpress.org/changeset/3096459/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b478d88d-1423-4a33-b8ef-08b9e66a5d98?source=cve
Get alerted when CVE-2024-4001 or the next vulnerability affects your stack