What’s Vulnerable › Vulnerabilities

CVE-2024-4006: Incorrect Authorization in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 16.7 before 16.9.6, all versions starting from 16.10 before 16.10.4, all versions starting from 16.11 before 16.11.1 where personal access scopes were not honored by GraphQL subscriptions

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.10.4, 16.9.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-4006 or the next vulnerability affects your stack