What’s Vulnerable › Vulnerabilities
CVE-2024-4024: Authentication Bypass by Assumed-Immutable Data in GitLab
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-25 · updated 2026-06-17
- Weakness: CWE-302
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 7.8 before 16.9.6, all versions starting from 16.10 before 16.10.4, all versions starting from 16.11 before 16.11.1. Under certain conditions, an attacker with their Bitbucket account credentials may be able to take over a GitLab account linked to another user's Bitbucket account, if Bitbucket is used as an OAuth 2.0 provider on GitLab.
Affected products
- GitLab: from 7.8.0 before 16.9.6; from 16.10.0 before 16.10.4; 16.11.0 — fixed in 16.10.4, 16.9.6
How to fix
Upgrade to a fixed version: GitLab 16.10.4, 16.9.6. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/452426
- https://gitlab.com/gitlab-org/gitlab/-/issues/452426
Get alerted when CVE-2024-4024 or the next vulnerability affects your stack