What’s Vulnerable › Vulnerabilities
CVE-2024-40347
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-20 · updated 2026-06-17
- Weakness: CWE-79
Description
A reflected cross-site scripting (XSS) vulnerability in Hyland Alfresco Platform 23.2.1-r96 allows attackers to execute arbitrary code in the context of a user's browser via injecting a crafted payload into the parameter htmlid.
Affected products
- Hyland Alfresco Content Services: before 23.3 — fixed in 23.3
How to fix
Upgrade to a fixed version: Hyland Alfresco Content Services 23.3. Check the vendor advisory for mitigations.
References
- https://github.com/4rdr/proofs/blob/main/info/Alfresco_Reflected_XSS_via_htmlid_parameter.md
- https://github.com/4rdr/proofs/blob/main/info/Alfresco_Reflected_XSS_via_htmlid_parameter.md
Get alerted when CVE-2024-40347 or the next vulnerability affects your stack