What’s Vulnerable › Vulnerabilities
CVE-2024-4036: Sydney Toolbox <= 1.30 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Sydney Toolbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the style parameter in all versions up to, and including, 1.30 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- smub Sydney Toolbox: before 1.31 — fixed in 1.31
How to fix
Upgrade to a fixed version: smub Sydney Toolbox 1.31. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/sydney-toolbox/trunk/inc/elementor/block-employee.php#L346
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3075394%40sydney-toolbox%2Ftrunk&old=3064481%40sydney-toolbox%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c6d5275d-43d0-41f6-96c7-e7646eac4534?source=cve
- https://plugins.trac.wordpress.org/browser/sydney-toolbox/trunk/inc/elementor/block-employee.php#L346
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3075394%40sydney-toolbox%2Ftrunk&old=3064481%40sydney-toolbox%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c6d5275d-43d0-41f6-96c7-e7646eac4534?source=cve
Get alerted when CVE-2024-4036 or the next vulnerability affects your stack