What’s Vulnerable › Vulnerabilities
CVE-2024-40427
- Severity: high (CVSS 7.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-07 · updated 2026-06-17
- Weakness: CWE-120
Description
Stack Buffer Overflow in PX4-Autopilot v1.14.3, which allows attackers to execute commands to exploit this vulnerability and cause the program to refuse to execute
Affected products
- PX4-Autopilot: before 1.14.3 — fixed in 1.14.3
How to fix
Upgrade to a fixed version: PX4-Autopilot 1.14.3. Check the vendor advisory for mitigations.
References
- https://github.com/PX4/PX4-Autopilot/commit/e03e0261a1a0c82f545e66a1e3795956c886db71
- https://github.com/PX4/PX4-Autopilot/security/advisories/GHSA-55wq-2hgm-75m4
- https://github.com/PX4/PX4-Autopilot/security/advisories/GHSA-55wq-2hgm-75m4
Get alerted when CVE-2024-40427 or the next vulnerability affects your stack