What’s Vulnerable › Vulnerabilities
CVE-2024-40539
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-12 · updated 2026-06-17
- Weakness: CWE-89
Description
my-springsecurity-plus before v2024.07.03 was discovered to contain a SQL injection vulnerability via the dataScope parameter at /api/user.
Affected products
- Codermy My-Springsecurity-Plus: before 2024.07.03 — fixed in 2024.07.03
How to fix
Upgrade to a fixed version: Codermy My-Springsecurity-Plus 2024.07.03. Check the vendor advisory for mitigations.
References
- https://gitee.com/witmy/my-springsecurity-plus/issues/IAAE8U
- https://gitee.com/witmy/my-springsecurity-plus/issues/IAAE8U
Get alerted when CVE-2024-40539 or the next vulnerability affects your stack