What’s Vulnerable › Vulnerabilities
CVE-2024-40584
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-11 · updated 2026-06-17
- Weakness: CWE-78
Description
An improper neutralization of special elements used in an OS command ('OS Command Injection') vulnerability [CWE-78] in Fortinet FortiAnalyzer version 7.4.0 through 7.4.3, 7.2.0 through 7.2.5, 7.0.0 through 7.0.13, 6.4.0 through 6.4.15 and 6.2.2 through 6.2.13, Fortinet FortiManager version 7.4.0 through 7.4.3, 7.2.0 through 7.2.5, 7.0.0 through 7.0.13, 6.4.0 through 6.4.15 and 6.2.2 through 6.2.13, Fortinet FortiAnalyzer BigData version 7.4.0, 7.2.0 through 7.2.7, 7.0.1 through 7.0.6, 6.4.5 through 6.4.7 and 6.2.5, Fortinet FortiAnalyzer Cloud version 7.4.1 through 7.4.3, 7.2.1 through 7.2.5, 7.0.1 through 7.0.13 and 6.4.1 through 6.4.7 and Fortinet FortiManager Cloud version 7.4.1 through 7.4.3, 7.2.1 through 7.2.5, 7.0.1 through 7.0.13 and 6.4.1 through 6.4.7 GUI allows an authenticated privileged attacker to execute unauthorized code or commands via crafted HTTPS or HTTP requests.
Affected products
- Fortinet FortiAnalyzer: from 6.2.2 before 7.2.6; from 7.4.0 before 7.4.4 — fixed in 7.2.6, 7.4.4
- Fortinet Fortianalyzer Big Data: from 6.2.1 before 7.2.8; 7.4.0 — fixed in 7.2.8
- Fortinet FortiAnalyzer Cloud: from 6.4.1 before 7.2.6; from 7.4.1 before 7.4.4 — fixed in 7.2.6, 7.4.4
- Fortinet FortiManager: from 6.2.2 through 6.2.13; from 6.4.0 before 7.2.6; from 7.4.0 before 7.4.4 — fixed in 7.2.6, 7.4.4
- Fortinet FortiManager Cloud: from 6.4.1 through 7.0.14; from 7.2.1 before 7.2.6; from 7.4.1 before 7.4.4 — fixed in 7.2.6, 7.4.4
How to fix
Upgrade to a fixed version: Fortinet FortiAnalyzer 7.2.6, 7.4.4; Fortinet Fortianalyzer Big Data 7.2.8; Fortinet FortiAnalyzer Cloud 7.2.6, 7.4.4; Fortinet FortiManager 7.2.6, 7.4.4; Fortinet FortiManager Cloud 7.2.6, 7.4.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-40584 or the next vulnerability affects your stack