What’s Vulnerable › Vulnerabilities
CVE-2024-40587
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-14 · updated 2026-06-17
- Weakness: CWE-78
Description
An improper neutralization of special elements used in an OS command ('OS Command Injection') vulnerability [CWE-78] in Fortinet FortiVoice version 7.0.0 through 7.0.4 and before 6.4.9 allows an authenticated privileged attacker to execute unauthorized code or commands via crafted CLI requests.
Affected products
- Fortinet FortiVoice: from 6.0.0 before 6.4.10; from 7.0.0 before 7.0.5 — fixed in 6.4.10, 7.0.5
How to fix
Upgrade to a fixed version: Fortinet FortiVoice 6.4.10, 7.0.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-40587 or the next vulnerability affects your stack