What’s Vulnerable › Vulnerabilities

CVE-2024-40590

Description

An improper certificate validation vulnerability [CWE-295] in FortiPortal version 7.4.0, version 7.2.4 and below, version 7.0.8 and below, version 6.0.15 and below when connecting to a FortiManager device, a FortiAnalyzer device, or an SMTP server may allow an unauthenticated attacker in a Man-in-the-Middle position to intercept on and tamper with the encrypted communication channel established between the FortiPortal and those endpoints.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiPortal 7.0.9, 7.2.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-40590 or the next vulnerability affects your stack