What’s Vulnerable › Vulnerabilities
CVE-2024-40591
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-11 · updated 2026-06-17
- Weakness: CWE-266
Description
An incorrect privilege assignment vulnerability [CWE-266] in Fortinet FortiOS version 7.6.0, 7.4.0 through 7.4.4, 7.2.0 through 7.2.9 and before 7.0.15 allows an authenticated admin whose access profile has the Security Fabric permission to escalate their privileges to super-admin by connecting the targetted FortiGate to a malicious upstream FortiGate they control.
Affected products
- Fortinet FortiOS (FortiGate): from 6.4.0 before 6.4.16; from 7.0.0 before 7.0.16; from 7.2.0 before 7.2.10; from 7.4.0 before 7.4.5; 7.6.0 — fixed in 6.4.16, 7.0.16, 7.2.10, 7.4.5
How to fix
Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 6.4.16, 7.0.16, 7.2.10, 7.4.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-40591 or the next vulnerability affects your stack