What’s Vulnerable › Vulnerabilities
CVE-2024-40595
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-24 · updated 2026-06-17
- Weakness: CWE-319
Description
An authentication-bypass issue in the RDP component of One Identity Safeguard for Privileged Sessions (SPS) On Premise before 7.5.1 (and LTS before 7.0.5.1) allows man-in-the-middle attackers to obtain access to privileged sessions on target resources by intercepting cleartext RDP protocol information.
Affected products
- OneIdentity Safeguard For Privileged Sessions: before 7.5.1; before 7.0.5.1_lts — fixed in 7.0.5.1_lts, 7.5.1
How to fix
Upgrade to a fixed version: OneIdentity Safeguard For Privileged Sessions 7.0.5.1_lts, 7.5.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-40595 or the next vulnerability affects your stack