What’s Vulnerable › Vulnerabilities
CVE-2024-40618
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-11 · updated 2026-06-17
- Weakness: CWE-79
Description
Whale browser before 3.26.244.21 allows an attacker to execute malicious JavaScript due to improper sanitization when processing a built-in extension.
Affected products
- NAVER Whale Browser: before 3.26.244.21 — fixed in 3.26.244.21
How to fix
Upgrade to a fixed version: NAVER Whale Browser 3.26.244.21. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-40618 or the next vulnerability affects your stack