What’s Vulnerable › Vulnerabilities
CVE-2024-40625: GeoServer Coverage REST API Allows Server Side Request Forgery
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-10 · updated 2026-06-17
- Weakness: CWE-918
Description
GeoServer is an open source server that allows users to share and edit geospatial data. The Coverage rest api /workspaces/{workspaceName}/coveragestores/{storeName}/{method}.{format} allows attackers to upload files with a specified url (with {method} equals 'url') with no restrict. This vulnerability is fixed in 2.26.0.
Affected products
- geoserver org.geoserver.extension:gs-db2: before 2.26.0 — fixed in 2.26.0
How to fix
Upgrade to a fixed version: geoserver org.geoserver.extension:gs-db2 2.26.0. Check the vendor advisory for mitigations.
References
- https://github.com/geoserver/geoserver/security/advisories/GHSA-r4hf-r8gj-jgw2
- https://osgeo-org.atlassian.net/browse/GEOS-11468
- https://osgeo-org.atlassian.net/browse/GEOS-11717
Get alerted when CVE-2024-40625 or the next vulnerability affects your stack