What’s Vulnerable › Vulnerabilities
CVE-2024-40629: Arbitrary File Write in Ansible Playbooks leads to RCE in Jumpserver
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-18 · updated 2026-06-17
- Weakness: CWE-22
Description
JumpServer is an open-source Privileged Access Management (PAM) tool that provides DevOps and IT teams with on-demand and secure access to SSH, RDP, Kubernetes, Database and RemoteApp endpoints through a web browser. An attacker can exploit the Ansible playbook to write arbitrary files, leading to remote code execution (RCE) in the Celery container. The Celery container runs as root and has database access, allowing an attacker to steal all secrets for hosts, create a new JumpServer account with admin privileges, or manipulate the database in other ways. This issue has been patched in release versions 3.10.12 and 4.0.0. It is recommended to upgrade the safe versions. There are no known workarounds for this vulnerability.
Affected products
- jumpserver: from 3.0.0 before 3.10.12 — fixed in 3.10.12
How to fix
Upgrade to a fixed version: jumpserver 3.10.12. Check the vendor advisory for mitigations.
References
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-3wgp-q8m7-v33v
- https://www.sonarsource.com/blog/diving-into-jumpserver-attackers-gateway-to-internal-networks-2-2
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-3wgp-q8m7-v33v
Get alerted when CVE-2024-40629 or the next vulnerability affects your stack