What’s Vulnerable › Vulnerabilities
CVE-2024-40635: containerd has an integer overflow in User ID handling
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-17 · updated 2026-06-17
- Weakness: CWE-190
Description
containerd is an open-source container runtime. A bug was found in containerd prior to versions 1.6.38, 1.7.27, and 2.0.4 where containers launched with a User set as a `UID:GID` larger than the maximum 32-bit signed integer can cause an overflow condition where the container ultimately runs as root (UID 0). This could cause unexpected behavior for environments that require containers to run as a non-root user. This bug has been fixed in containerd 1.6.38, 1.7.27, and 2.04. As a workaround, ensure that only trusted images are used and that only trusted users have permissions to import images.
Affected products
- Debian Linux: 11.0
- containerd: before 1.6.38; from 1.7.0 before 1.7.27; from 2.0.0 before 2.0.4 — fixed in 1.6.38, 1.7.27, 2.0.4
How to fix
Upgrade to a fixed version: containerd 1.6.38, 1.7.27, 2.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/containerd/containerd/commit/05044ec0a9a75232cad458027ca83437aae3f4da
- https://github.com/containerd/containerd/commit/1a43cb6a1035441f9aca8f5666a9b3ef9e70ab20
- https://github.com/containerd/containerd/commit/cf158e884cfe4812a6c371b59e4ea9bc4c46e51a
- https://github.com/containerd/containerd/security/advisories/GHSA-265r-hfxg-fhmg
- https://lists.debian.org/debian-lts-announce/2025/05/msg00005.html
Get alerted when CVE-2024-40635 or the next vulnerability affects your stack