What’s Vulnerable › Vulnerabilities
CVE-2024-40643: Joplin has a parsing error leading to Cross-site Scripting (XSS)
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Joplin is a free, open source note taking and to-do application. Joplin fails to take into account that "<" followed by a non letter character will not be considered html. As such it is possible to do an XSS by putting an "illegal" tag within a tag.
Affected products
- laurent22 joplin: before 3.0.15 — fixed in 3.0.15
How to fix
Upgrade to a fixed version: laurent22 joplin 3.0.15. Check the vendor advisory for mitigations.
References
- https://github.com/laurent22/joplin/commit/b220413a9b5ed55fb1f565ac786a5c231da8bc87
- https://github.com/laurent22/joplin/security/advisories/GHSA-g796-3g6g-jmmc
Get alerted when CVE-2024-40643 or the next vulnerability affects your stack