What’s Vulnerable › Vulnerabilities
CVE-2024-40717
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-04 · updated 2026-06-17
- Weakness: CWE-306
Description
A vulnerability in Veeam Backup & Replication allows a low-privileged user with certain roles to perform remote code execution (RCE) by updating existing jobs. These jobs can be configured to run pre- and post-scripts, which can be located on a network share and are executed with elevated privileges by default. The user can update a job and schedule it to run almost immediately, allowing arbitrary code execution on the server.
Affected products
- Veeam Backup & Replication: from 12.0.0.1402 before 12.3.0.310 — fixed in 12.3.0.310
How to fix
Upgrade to a fixed version: Veeam Backup & Replication 12.3.0.310. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-40717 or the next vulnerability affects your stack