What’s Vulnerable › Vulnerabilities
CVE-2024-40724
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-19 · updated 2026-06-17
- Weakness: CWE-787
Description
Heap-based buffer overflow vulnerability in Assimp versions prior to 5.4.2 allows a local attacker to execute arbitrary code by inputting a specially crafted file into the product.
Affected products
- Open Asset Import Library Assimp: before 5.4.2 — fixed in 5.4.2
How to fix
Upgrade to a fixed version: Open Asset Import Library Assimp 5.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/assimp/assimp/pull/5651/commits/614911bb3b1bfc3a1799ae2b3cca306270f3fb97
- https://github.com/assimp/assimp/releases/tag/v5.4.2
- https://jvn.jp/en/jp/JVN87710540/
- https://github.com/assimp/assimp/pull/5651/commits/614911bb3b1bfc3a1799ae2b3cca306270f3fb97
- https://github.com/assimp/assimp/releases/tag/v5.4.2
- https://jvn.jp/en/jp/JVN87710540/
Get alerted when CVE-2024-40724 or the next vulnerability affects your stack