What’s Vulnerable › Vulnerabilities
CVE-2024-40764
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-18 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based buffer overflow vulnerability in the SonicOS IPSec VPN allows an unauthenticated remote attacker to cause Denial of Service (DoS).
Affected products
- SonicWall SonicOS: before 6.5.4.v-21s-rc2457; before 7.0.1-5161; from 7.1.1-7040 before 7.1.1-7058 — fixed in 6.5.4.v-21s-rc2457, 7.0.1-5161, 7.1.1-7058
How to fix
Upgrade to a fixed version: SonicWall SonicOS 6.5.4.v-21s-rc2457, 7.0.1-5161, 7.1.1-7058. Check the vendor advisory for mitigations.
References
- https://psirt.global.sonicwall.com/vuln-detail/SNWLID-2024-0012
- https://psirt.global.sonicwall.com/vuln-detail/SNWLID-2024-0012
Get alerted when CVE-2024-40764 or the next vulnerability affects your stack