What’s Vulnerable › Vulnerabilities
CVE-2024-40802
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-29 · updated 2026-06-17
- Weakness: CWE-269
Description
The issue was addressed with improved checks. This issue is fixed in macOS Monterey 12.7.6, macOS Sonoma 14.6, macOS Ventura 13.6.8. A local attacker may be able to elevate their privileges.
Affected products
- Apple macOS: from 12.0 before 12.7.6; from 13.0 before 13.6.8; from 14.0 before 14.6 — fixed in 12.7.6, 13.6.8, 14.6
How to fix
Upgrade to a fixed version: Apple macOS 12.7.6, 13.6.8, 14.6. Check the vendor advisory for mitigations.
References
- https://support.apple.com/en-us/120910
- https://support.apple.com/en-us/120911
- https://support.apple.com/en-us/120912
- http://seclists.org/fulldisclosure/2024/Jul/18
- http://seclists.org/fulldisclosure/2024/Jul/19
- http://seclists.org/fulldisclosure/2024/Jul/20
- https://support.apple.com/en-us/HT214118
- https://support.apple.com/en-us/HT214119
- https://support.apple.com/en-us/HT214120
- https://support.apple.com/kb/HT214118
- https://support.apple.com/kb/HT214119
- https://support.apple.com/kb/HT214120
Get alerted when CVE-2024-40802 or the next vulnerability affects your stack