What’s Vulnerable › Vulnerabilities
CVE-2024-4088: Gutenberg Blocks and Page Layouts – Attire Blocks <= 1.9.2 - Missing Authorization
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-05 · updated 2026-06-17
- Weakness: CWE-862
Description
The Gutenberg Blocks and Page Layouts – Attire Blocks plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the disable_fe_assets function in all versions up to, and including, 1.9.2. This makes it possible for authenticated attackers, with subscriber access or above, to change the plugin's settings. Additionally, no nonce check is performed resulting in a CSRF vulnerability.
Affected products
- shafayat-alam Gutenberg Blocks and Page Layouts – Attire Blocks: before 1.9.3 — fixed in 1.9.3
How to fix
Upgrade to a fixed version: shafayat-alam Gutenberg Blocks and Page Layouts – Attire Blocks 1.9.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3085600/attire-blocks/trunk/admin/AttireBlocksSettings.php?old=2996841&old_path=attire-blocks%2Ftrunk%2Fadmin%2FAttireBlocksSettings.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ef47feb7-76fd-470d-ba48-55ba3c323c6d?source=cve
- https://plugins.trac.wordpress.org/changeset/3085600/attire-blocks/trunk/admin/AttireBlocksSettings.php?old=2996841&old_path=attire-blocks%2Ftrunk%2Fadmin%2FAttireBlocksSettings.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ef47feb7-76fd-470d-ba48-55ba3c323c6d?source=cve
Get alerted when CVE-2024-4088 or the next vulnerability affects your stack