What’s Vulnerable › Vulnerabilities
CVE-2024-40892: Firewalla BTLE Weak Credentials
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-12 · updated 2026-06-17
- Weakness: CWE-1391
Description
A weak credential vulnerability exists in Firewalla Box Software versions before 1.979. This vulnerability allows a physically close attacker to use the license UUID for authentication and provision SSH credentials over the Bluetooth Low-Energy (BTLE) interface. Once an attacker gains access to the LAN, they could log into the SSH interface using the provisioned credentials. The license UUID can be acquired through plain-text Bluetooth sniffing, reading the QR code on the bottom of the device, or brute-forcing the UUID (though this is less likely).
Affected products
- Firewalla Box Software: before 1.979 — fixed in 1.979
How to fix
Upgrade to a fixed version: Firewalla Box Software 1.979. Check the vendor advisory for mitigations.
References
- https://vulncheck.com/advisories/firewalla-bt-weak-credentials
- https://www.labs.greynoise.io/grimoire/2024-08-20-bluuid-firewalla/
Get alerted when CVE-2024-40892 or the next vulnerability affects your stack