What’s Vulnerable › Vulnerabilities

CVE-2024-40896

Description

In libxml2 2.11 before 2.11.9, 2.12 before 2.12.9, and 2.13 before 2.13.3, the SAX parser can produce events for external entities even if custom SAX handlers try to override entity content (by setting "checked"). This makes classic XXE attacks possible.

Affected products

How to fix

Upgrade to a fixed version: xmlsoft libxml2 2.11.9, 2.12.9, 2.13.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-40896 or the next vulnerability affects your stack