What’s Vulnerable › Vulnerabilities
CVE-2024-40897
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-26 · updated 2026-06-17
- Weakness: CWE-787
Description
Stack-based buffer overflow vulnerability exists in orcparse.c of ORC versions prior to 0.4.39. If a developer is tricked to process a specially crafted file with the affected ORC compiler, an arbitrary code may be executed on the developer's build environment. This may lead to compromise of developer machines or CI build environments.
Affected products
- GStreamer ORC: before 0.4.39 — fixed in 0.4.39
How to fix
Upgrade to a fixed version: GStreamer ORC 0.4.39. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/07/26/1
- https://github.com/GStreamer/orc
- https://gstreamer.freedesktop.org/modules/orc.html
- https://jvn.jp/en/jp/JVN02030803/
- http://www.openwall.com/lists/oss-security/2024/07/26/1
- https://github.com/GStreamer/orc
- https://gstreamer.freedesktop.org/modules/orc.html
- https://jvn.jp/en/jp/JVN02030803/
Get alerted when CVE-2024-40897 or the next vulnerability affects your stack