What’s Vulnerable › Vulnerabilities
CVE-2024-4090: My Sticky Bar < 2.7.2 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Floating Notification Bar, Sticky Menu on Scroll, Announcement Banner, and Sticky Header for Any WordPress plugin before 2.7.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
Affected products
- Floating Notification Bar, Sticky Menu on Scroll, Announcement Banner, and Sticky Header for Any Theme: before 2.7.2 — fixed in 2.7.2
How to fix
Upgrade to a fixed version: Floating Notification Bar, Sticky Menu on Scroll, Announcement Banner, and Sticky Header for Any Theme 2.7.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-4090 or the next vulnerability affects your stack