What’s Vulnerable › Vulnerabilities
CVE-2024-4091: Responsive Gallery Grid < 2.3.15 - Admin+ Stored XSS
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Responsive Gallery Grid WordPress plugin before 2.3.15 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
Affected products
- Responsive Gallery Grid: before 2.3.15 — fixed in 2.3.15
How to fix
Upgrade to a fixed version: Responsive Gallery Grid 2.3.15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-4091 or the next vulnerability affects your stack