What’s Vulnerable › Vulnerabilities
CVE-2024-40917: memblock: make memblock_set_node() also warn about use of MAX_NUMNODES
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-12 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: memblock: make memblock_set_node() also warn about use of MAX_NUMNODES On an (old) x86 system with SRAT just covering space above 4Gb: ACPI: SRAT: Node 0 PXM 0 [mem 0x100000000-0xfffffffff] hotplug the commit referenced below leads to this NUMA configuration no longer being refused by a CONFIG_NUMA=y kernel (previously NUMA: nodes only cover 6144MB of your 8185MB e820 RAM. Not used. No NUMA configuration found Faking a node at [mem 0x0000000000000000-0x000000027fffffff] was seen in the log directly after the message quoted above), because of memblock_validate_numa_coverage() checking for NUMA_NO_NODE (only). This in turn led to memblock_alloc_range_nid()'s warning about MAX_NUMNODES triggering, followed by a NULL deref in memmap_init() when trying to access node 64's (NODE_SHIFT=6) node data. To compensate said change, make memblock_set_node() warn on and adjust a passed in value of MAX_NUMNODES, just like various other functions already do.
Affected products
- Linux kernel: from 6.6.70 before 6.6.72; from 6.8 before 6.9.6; 6.10-rc1, 6.10-rc2, 6.10-rc3 — fixed in 6.6.72, 6.9.6
How to fix
Upgrade to a fixed version: Linux kernel 6.6.72, 6.9.6. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/22f742b8f738918f683198a18ec3c691acda14c4
- https://git.kernel.org/stable/c/4ddb7f966f3d06fcf1ba5ee298af6714b593584b
- https://git.kernel.org/stable/c/e0eec24e2e199873f43df99ec39773ad3af2bff7
- https://git.kernel.org/stable/c/22f742b8f738918f683198a18ec3c691acda14c4
- https://git.kernel.org/stable/c/e0eec24e2e199873f43df99ec39773ad3af2bff7
Get alerted when CVE-2024-40917 or the next vulnerability affects your stack