What’s Vulnerable › Vulnerabilities
CVE-2024-4092: Slider Revolution <= 6.7.7 - Authenticated (Author+) Stored Cross-Site Scripting via htmltag Parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Slider Revolution plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘htmltag’ parameter in all versions up to, and including, 6.7.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. By default, this can only be exploited by administrators, but the ability to use and configure Slider Revolution can be extended to authors.
Affected products
- Revolution Slider Slider Revolution: before 6.7.8 — fixed in 6.7.8
How to fix
Upgrade to a fixed version: Revolution Slider Slider Revolution 6.7.8. Check the vendor advisory for mitigations.
References
- https://www.sliderrevolution.com/documentation/changelog/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8437abcc-3e34-4a8a-bfe2-2ff7c9f41164?source=cve
- https://www.sliderrevolution.com/documentation/changelog/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8437abcc-3e34-4a8a-bfe2-2ff7c9f41164?source=cve
Get alerted when CVE-2024-4092 or the next vulnerability affects your stack