What’s Vulnerable › Vulnerabilities
CVE-2024-40920: net: bridge: mst: fix suspicious rcu usage in br_mst_set_state
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-12 · updated 2026-08-04
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: net: bridge: mst: fix suspicious rcu usage in br_mst_set_state I converted br_mst_set_state to RCU to avoid a vlan use-after-free but forgot to change the vlan group dereference helper. Switch to vlan group RCU deref helper to fix the suspicious rcu usage warning.
Affected products
- Linux kernel: from 6.1.93 before 6.1.95; from 6.6.33 before 6.6.35; from 6.8.12 before 6.9; from 6.9.3 before 6.9.6; 6.10-rc1, 6.10-rc2, 6.10-rc3 — fixed in 6.1.95, 6.6.35, 6.9, 6.9.6
How to fix
Upgrade to a fixed version: Linux kernel 6.1.95, 6.6.35, 6.9, 6.9.6. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/406bfc04b01ee47e4c626f77ecc7d9f85135b166
- https://git.kernel.org/stable/c/546ceb1dfdac866648ec959cbc71d9525bd73462
- https://git.kernel.org/stable/c/7caefa2771722e65496d85b62e1dc4442b7d1345
- https://git.kernel.org/stable/c/caaa2129784a04dcade0ea92c12e6ff90bbd23d8
- https://git.kernel.org/stable/c/406bfc04b01ee47e4c626f77ecc7d9f85135b166
- https://git.kernel.org/stable/c/546ceb1dfdac866648ec959cbc71d9525bd73462
- https://git.kernel.org/stable/c/7caefa2771722e65496d85b62e1dc4442b7d1345
- https://git.kernel.org/stable/c/caaa2129784a04dcade0ea92c12e6ff90bbd23d8
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-40920 or the next vulnerability affects your stack