What’s Vulnerable › Vulnerabilities
CVE-2024-40930: wifi: cfg80211: validate HE operation element parsing
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-12 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: cfg80211: validate HE operation element parsing Validate that the HE operation element has the correct length before parsing it.
Affected products
- Linux kernel: from 6.8 before 6.9.6; 6.10-rc1, 6.10-rc2 — fixed in 6.9.6
How to fix
Upgrade to a fixed version: Linux kernel 6.9.6. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4dc3a3893dae5a7f73e5809273aca0f1f3548d55
- https://git.kernel.org/stable/c/f15e3e13e14cc5ae8f950c16efe706add18ac8e2
- https://git.kernel.org/stable/c/4dc3a3893dae5a7f73e5809273aca0f1f3548d55
- https://git.kernel.org/stable/c/f15e3e13e14cc5ae8f950c16efe706add18ac8e2
Get alerted when CVE-2024-40930 or the next vulnerability affects your stack