What’s Vulnerable › Vulnerabilities
CVE-2024-4094: Simple Share Buttons Adder < 8.5.1 - Admin+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Simple Share Buttons Adder WordPress plugin before 8.5.1 does not sanitise and escape some of its settings, which could allow high privilege users such as editors to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
Affected products
- Simple Share Buttons Adder: before 8.5.1 — fixed in 8.5.1
How to fix
Upgrade to a fixed version: Simple Share Buttons Adder 8.5.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/04b2feba-e009-4fce-8539-5dfdb4300433/
- https://wpscan.com/vulnerability/04b2feba-e009-4fce-8539-5dfdb4300433/
Get alerted when CVE-2024-4094 or the next vulnerability affects your stack