What’s Vulnerable › Vulnerabilities
CVE-2024-40941: wifi: iwlwifi: mvm: don't read past the mfuart notifcation
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-12 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: iwlwifi: mvm: don't read past the mfuart notifcation In case the firmware sends a notification that claims it has more data than it has, we will read past that was allocated for the notification. Remove the print of the buffer, we won't see it by default. If needed, we can see the content with tracing. This was reported by KFENCE.
Affected products
- Linux kernel: from 4.12 before 4.19.317; from 4.20 before 5.4.279; from 5.5 before 5.10.221; from 5.11 before 5.15.162; from 5.16 before 6.1.95; from 6.2 before 6.6.35 — fixed in 4.19.317, 5.10.221, 5.15.162, 5.4.279, 6.1.95, 6.6.35
How to fix
Upgrade to a fixed version: Linux kernel 4.19.317, 5.10.221, 5.15.162, 5.4.279. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/15b37c6fab9d5e40ac399fa1c725118588ed649c
- https://git.kernel.org/stable/c/46c59a25337049a2a230ce7f7c3b9f21d0aaaad7
- https://git.kernel.org/stable/c/4bb95f4535489ed830cf9b34b0a891e384d1aee4
- https://git.kernel.org/stable/c/6532f18e66b384b8d4b7e5c9caca042faaa9e8de
- https://git.kernel.org/stable/c/65686118845d427df27ee83a6ddd4885596b0805
- https://git.kernel.org/stable/c/a05018739a5e6b9dc112c95bd4c59904062c8940
- https://git.kernel.org/stable/c/a8bc8276af9aeacabb773f0c267cfcdb847c6f2d
- https://git.kernel.org/stable/c/acdfa33c3cf5e1cd185cc1e0486bd0ea9f09c154
- https://git.kernel.org/stable/c/15b37c6fab9d5e40ac399fa1c725118588ed649c
- https://git.kernel.org/stable/c/46c59a25337049a2a230ce7f7c3b9f21d0aaaad7
- https://git.kernel.org/stable/c/4bb95f4535489ed830cf9b34b0a891e384d1aee4
- https://git.kernel.org/stable/c/6532f18e66b384b8d4b7e5c9caca042faaa9e8de
Get alerted when CVE-2024-40941 or the next vulnerability affects your stack