What’s Vulnerable › Vulnerabilities
CVE-2024-40948: mm/page_table_check: fix crash on ZONE_DEVICE
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-12 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: mm/page_table_check: fix crash on ZONE_DEVICE Not all pages may apply to pgtable check. One example is ZONE_DEVICE pages: they map PFNs directly, and they don't allocate page_ext at all even if there's struct page around. One may reference devm_memremap_pages(). When both ZONE_DEVICE and page-table-check enabled, then try to map some dax memories, one can trigger kernel bug constantly now when the kernel was trying to inject some pfn maps on the dax device: kernel BUG at mm/page_table_check.c:55! While it's pretty legal to use set_pxx_at() for ZONE_DEVICE pages for page fault resolutions, skip all the checks if page_ext doesn't even exist in pgtable checker, which applies to ZONE_DEVICE but maybe more.
Affected products
- Linux kernel: from 5.17 before 6.1.96; from 6.2 before 6.6.36; from 6.7 before 6.9.7; 6.10-rc1, 6.10-rc2, 6.10-rc3, 6.10-rc4 — fixed in 6.1.96, 6.6.36, 6.9.7
How to fix
Upgrade to a fixed version: Linux kernel 6.1.96, 6.6.36, 6.9.7. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/51897f99351fff7b57f4f141940fa93b4e90fd2b
- https://git.kernel.org/stable/c/84d3549d54f5ff9fa3281257be3019386f51d1a0
- https://git.kernel.org/stable/c/8bb592c2eca8fd2bc06db7d80b38da18da4a2f43
- https://git.kernel.org/stable/c/dec2382247860d2134c8d41e103e26460c099629
- https://git.kernel.org/stable/c/51897f99351fff7b57f4f141940fa93b4e90fd2b
- https://git.kernel.org/stable/c/84d3549d54f5ff9fa3281257be3019386f51d1a0
- https://git.kernel.org/stable/c/8bb592c2eca8fd2bc06db7d80b38da18da4a2f43
- https://git.kernel.org/stable/c/dec2382247860d2134c8d41e103e26460c099629
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-40948 or the next vulnerability affects your stack