What’s Vulnerable › Vulnerabilities
CVE-2024-40956: dmaengine: idxd: Fix possible Use-After-Free in irq_process_work_list
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-12 · updated 2026-08-04
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: dmaengine: idxd: Fix possible Use-After-Free in irq_process_work_list Use list_for_each_entry_safe() to allow iterating through the list and deleting the entry in the iteration process. The descriptor is freed via idxd_desc_complete() and there's a slight chance may cause issue for the list iterator when the descriptor is reused by another thread without it being deleted from the list.
Affected products
- Linux kernel: from 5.11 before 5.15.162; from 5.16 before 6.1.96; from 6.2 before 6.6.36; from 6.7 before 6.9.7; 6.10-rc1, 6.10-rc2, 6.10-rc3, 6.10-rc4 — fixed in 5.15.162, 6.1.96, 6.6.36, 6.9.7
How to fix
Upgrade to a fixed version: Linux kernel 5.15.162, 6.1.96, 6.6.36, 6.9.7. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1b08bf5a17c66ab7dbb628df5344da53c8e7ab33
- https://git.kernel.org/stable/c/83163667d881100a485b6c2daa30301b7f68d9b5
- https://git.kernel.org/stable/c/a14968921486793f2a956086895c3793761309dd
- https://git.kernel.org/stable/c/e3215deca4520773cd2b155bed164c12365149a7
- https://git.kernel.org/stable/c/faa35db78b058a2ab6e074ee283f69fa398c36a8
- https://git.kernel.org/stable/c/1b08bf5a17c66ab7dbb628df5344da53c8e7ab33
- https://git.kernel.org/stable/c/83163667d881100a485b6c2daa30301b7f68d9b5
- https://git.kernel.org/stable/c/a14968921486793f2a956086895c3793761309dd
- https://git.kernel.org/stable/c/e3215deca4520773cd2b155bed164c12365149a7
- https://git.kernel.org/stable/c/faa35db78b058a2ab6e074ee283f69fa398c36a8
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-40956 or the next vulnerability affects your stack