What’s Vulnerable › Vulnerabilities
CVE-2024-4098: Shariff Wrapper <= 4.6.13 - Unauthenticated Local File Inclusion
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-20 · updated 2026-06-17
- Weakness: CWE-22
Description
The Shariff Wrapper plugin for WordPress is vulnerable to Local File Inclusion in versions up to, and including, 4.6.13 via the shariff3uu_fetch_sharecounts function. This allows unauthenticated attackers to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.
Affected products
- 3uu Shariff Wrapper: before 4.6.14 — fixed in 4.6.14
How to fix
Upgrade to a fixed version: 3uu Shariff Wrapper 4.6.14. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/shariff/trunk/shariff.php#L410
- https://plugins.trac.wordpress.org/changeset/3103137
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f49fba00-c576-4a1a-8b0b-9ebed3e3d090?source=cve
- https://plugins.trac.wordpress.org/browser/shariff/trunk/shariff.php#L410
- https://plugins.trac.wordpress.org/changeset/3103137
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f49fba00-c576-4a1a-8b0b-9ebed3e3d090?source=cve
Get alerted when CVE-2024-4098 or the next vulnerability affects your stack