What’s Vulnerable › Vulnerabilities
CVE-2024-40984: ACPICA: Revert "ACPICA: avoid Info: mapping multiple BARs. Your kernel is fine."
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-12 · updated 2026-10-15
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: ACPICA: Revert "ACPICA: avoid Info: mapping multiple BARs. Your kernel is fine." Undo the modifications made in commit d410ee5109a1 ("ACPICA: avoid "Info: mapping multiple BARs. Your kernel is fine.""). The initial purpose of this commit was to stop memory mappings for operation regions from overlapping page boundaries, as it can trigger warnings if different page attributes are present. However, it was found that when this situation arises, mapping continues until the boundary's end, but there is still an attempt to read/write the entire length of the map, leading to a NULL pointer deference. For example, if a four-byte mapping request is made but only one byte is mapped because it hits the current page boundary's end, a four-byte read/write attempt is still made, resulting in a NULL pointer deference. Instead, map the entire length, as the ACPI specification does not mandate that it must be within the same page boundary. It is permissible for it to be mapped across different regions.
Affected products
- Linux kernel: from 2.6.32 before 4.19.317; from 4.20 before 5.4.279; from 5.5 before 5.10.221; from 5.11 before 5.15.162; from 5.16 before 6.1.96; from 6.2 before 6.6.36 — fixed in 4.19.317, 5.10.221, 5.15.162, 5.4.279, 6.1.96, 6.6.36
How to fix
Upgrade to a fixed version: Linux kernel 4.19.317, 5.10.221, 5.15.162, 5.4.279. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/434c6b924e1f4c219aab2d9e05fe79c5364e37d3
- https://git.kernel.org/stable/c/435ecc978c3d5d0c4e172ec5b956dc1904061d98
- https://git.kernel.org/stable/c/6eca23100e9030725f69c1babacd58803f29ec8d
- https://git.kernel.org/stable/c/a83e1385b780d41307433ddbc86e3c528db031f0
- https://git.kernel.org/stable/c/ae465109d82f4fb03c5adbe85f2d6a6a3d59124c
- https://git.kernel.org/stable/c/dc5017c57f5eee80020c73ff8b67ba7f9fd08b1f
- https://git.kernel.org/stable/c/ddc1f5f124479360a1fd43f73be950781d172239
- https://git.kernel.org/stable/c/e21a4c9129c72fa54dd00f5ebf71219b41d43c04
- https://git.kernel.org/stable/c/434c6b924e1f4c219aab2d9e05fe79c5364e37d3
- https://git.kernel.org/stable/c/435ecc978c3d5d0c4e172ec5b956dc1904061d98
- https://git.kernel.org/stable/c/6eca23100e9030725f69c1babacd58803f29ec8d
- https://git.kernel.org/stable/c/a83e1385b780d41307433ddbc86e3c528db031f0
Get alerted when CVE-2024-40984 or the next vulnerability affects your stack