What’s Vulnerable › Vulnerabilities

CVE-2024-4099: Improper Encoding or Escaping of Output in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions starting from 16.0 prior to 17.2.8, from 17.3 prior to 17.3.4, and from 17.4 prior to 17.4.1. An AI feature was found to read unsanitized content in a way that could have allowed an attacker to hide prompt injection.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.2.8, 17.3.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-4099 or the next vulnerability affects your stack