What’s Vulnerable › Vulnerabilities
CVE-2024-40994: ptp: fix integer overflow in max_vclocks_store
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-12 · updated 2026-06-17
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: ptp: fix integer overflow in max_vclocks_store On 32bit systems, the "4 * max" multiply can overflow. Use kcalloc() to do the allocation to prevent this.
Affected products
- Linux kernel: from 5.14 before 5.15.162; from 5.16 before 6.1.96; from 6.2 before 6.6.36; from 6.7 before 6.9.7; 6.10-rc1, 6.10-rc2, 6.10-rc3, 6.10-rc4 — fixed in 5.15.162, 6.1.96, 6.6.36, 6.9.7
How to fix
Upgrade to a fixed version: Linux kernel 5.15.162, 6.1.96, 6.6.36, 6.9.7. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4b03da87d0b7074c93d9662c6e1a8939f9b8b86e
- https://git.kernel.org/stable/c/666e934d749e50a37f3796caaf843a605f115b6f
- https://git.kernel.org/stable/c/81d23d2a24012e448f651e007fac2cfd20a45ce0
- https://git.kernel.org/stable/c/d50d62d5e6ee6aa03c00bddb91745d0b632d3b0f
- https://git.kernel.org/stable/c/e1fccfb4638ee6188377867f6015d0ce35764a8e
- https://git.kernel.org/stable/c/4b03da87d0b7074c93d9662c6e1a8939f9b8b86e
- https://git.kernel.org/stable/c/666e934d749e50a37f3796caaf843a605f115b6f
- https://git.kernel.org/stable/c/81d23d2a24012e448f651e007fac2cfd20a45ce0
- https://git.kernel.org/stable/c/d50d62d5e6ee6aa03c00bddb91745d0b632d3b0f
- https://git.kernel.org/stable/c/e1fccfb4638ee6188377867f6015d0ce35764a8e
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-40994 or the next vulnerability affects your stack