What’s Vulnerable › Vulnerabilities
CVE-2024-41039: firmware: cs_dsp: Fix overflow checking of wmfw header
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-29 · updated 2026-06-17
- Weakness: CWE-120
Description
In the Linux kernel, the following vulnerability has been resolved: firmware: cs_dsp: Fix overflow checking of wmfw header Fix the checking that firmware file buffer is large enough for the wmfw header, to prevent overrunning the buffer. The original code tested that the firmware data buffer contained enough bytes for the sums of the size of the structs wmfw_header + wmfw_adsp1_sizes + wmfw_footer But wmfw_adsp1_sizes is only used on ADSP1 firmware. For ADSP2 and Halo Core the equivalent struct is wmfw_adsp2_sizes, which is 4 bytes longer. So the length check didn't guarantee that there are enough bytes in the firmware buffer for a header with wmfw_adsp2_sizes. This patch splits the length check into three separate parts. Each of the wmfw_header, wmfw_adsp?_sizes and wmfw_footer are checked separately before they are used.
Affected products
- Linux kernel: from 5.16 before 6.1.100; from 6.2 before 6.6.41; from 6.7 before 6.9.10; 6.10-rc1, 6.10-rc2, 6.10-rc3, 6.10-rc4, 6.10-rc5, 6.10-rc6 (+1) — fixed in 6.1.100, 6.6.41, 6.9.10
How to fix
Upgrade to a fixed version: Linux kernel 6.1.100, 6.6.41, 6.9.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3019b86bce16fbb5bc1964f3544d0ce7d0137278
- https://git.kernel.org/stable/c/49a79f344d0a17c6a5eef53716cc76fcdbfca9ba
- https://git.kernel.org/stable/c/9c9877a96e033bf6c6470b3b4f06106d91ace11e
- https://git.kernel.org/stable/c/fd035f0810b33c2a8792effdb82bf35920221565
- https://git.kernel.org/stable/c/3019b86bce16fbb5bc1964f3544d0ce7d0137278
- https://git.kernel.org/stable/c/49a79f344d0a17c6a5eef53716cc76fcdbfca9ba
- https://git.kernel.org/stable/c/9c9877a96e033bf6c6470b3b4f06106d91ace11e
- https://git.kernel.org/stable/c/fd035f0810b33c2a8792effdb82bf35920221565
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-41039 or the next vulnerability affects your stack