What’s Vulnerable › Vulnerabilities
CVE-2024-41042: netfilter: nf_tables: prefer nft_chain_validate
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-29 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: netfilter: nf_tables: prefer nft_chain_validate nft_chain_validate already performs loop detection because a cycle will result in a call stack overflow (ctx->level >= NFT_JUMP_STACK_SIZE). It also follows maps via ->validate callback in nft_lookup, so there appears no reason to iterate the maps again. nf_tables_check_loops() and all its helper functions can be removed. This improves ruleset load time significantly, from 23s down to 12s. This also fixes a crash bug. Old loop detection code can result in unbounded recursion: BUG: TASK stack guard page was hit at .... Oops: stack guard page: 0000 [#1] PREEMPT SMP KASAN CPU: 4 PID: 1539 Comm: nft Not tainted 6.10.0-rc5+ #1 [..] with a suitable ruleset during validation of register stores. I can't see any actual reason to attempt to check for this from nft_validate_register_store(), at this point the transaction is still in progress, so we don't have a full picture of the rule graph. For nf-next it might make sense to either remove it or make this depend on table->validate_state in case we could catch an error earlier (for improved error reporting to userspace).
Affected products
- Linux kernel: from 3.13 before 4.19.320; from 4.20 before 5.4.282; from 5.5 before 5.10.224; from 5.11 before 5.15.165; from 5.16 before 6.1.105; from 6.2 before 6.6.46 — fixed in 4.19.320, 5.10.224, 5.15.165, 5.4.282, 6.1.105, 6.6.46
How to fix
Upgrade to a fixed version: Linux kernel 4.19.320, 5.10.224, 5.15.165, 5.4.282. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1947e4c3346faa8ac7e343652c0fd3b3e394202f
- https://git.kernel.org/stable/c/31c35f9f89ef585f1edb53e17ac73a0ca4a9712b
- https://git.kernel.org/stable/c/717c91c6ed73e248de6a15bc53adefb81446c9d0
- https://git.kernel.org/stable/c/8246b7466c8da49d0d9e85e26cbd69dd6d3e3d1e
- https://git.kernel.org/stable/c/9df785aeb7dcc8efd1d4110bb27d26005298ebae
- https://git.kernel.org/stable/c/b6b6e430470e1c3c5513311cb35a15a205595abe
- https://git.kernel.org/stable/c/cd4348e0a50286282c314ad6d2b0740e7c812c24
- https://git.kernel.org/stable/c/cff3bd012a9512ac5ed858d38e6ed65f6391008c
- https://git.kernel.org/stable/c/9df785aeb7dcc8efd1d4110bb27d26005298ebae
- https://git.kernel.org/stable/c/cff3bd012a9512ac5ed858d38e6ed65f6391008c
- https://lists.debian.org/debian-lts-announce/2024/10/msg00003.html
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-41042 or the next vulnerability affects your stack