What’s Vulnerable › Vulnerabilities
CVE-2024-41044: ppp: reject claimed-as-LCP but actually malformed packets
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-29 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: ppp: reject claimed-as-LCP but actually malformed packets Since 'ppp_async_encode()' assumes valid LCP packets (with code from 1 to 7 inclusive), add 'ppp_check_packet()' to ensure that LCP packet has an actual body beyond PPP_LCP header bytes, and reject claimed-as-LCP but actually malformed data otherwise.
Affected products
- Linux kernel: from 2.6.13 before 4.19.318; from 4.20 before 5.4.280; from 5.5 before 5.10.222; from 5.11 before 5.15.163; from 5.16 before 6.1.100; from 6.2 before 6.6.41 — fixed in 4.19.318, 5.10.222, 5.15.163, 5.4.280, 6.1.100, 6.6.41
How to fix
Upgrade to a fixed version: Linux kernel 4.19.318, 5.10.222, 5.15.163, 5.4.280. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/099502ca410922b56353ccef2749bc0de669da78
- https://git.kernel.org/stable/c/3134bdf7356ed952dcecb480861d2afcc1e40492
- https://git.kernel.org/stable/c/3ba12c2afd933fc1bf800f6d3f6c7ec8f602ce56
- https://git.kernel.org/stable/c/6e8f1c21174f9482033bbb59f13ce1a8cbe843c3
- https://git.kernel.org/stable/c/97d1efd8be26615ff680cdde86937d5943138f37
- https://git.kernel.org/stable/c/d683e7f3fc48f59576af34631b4fb07fd931343e
- https://git.kernel.org/stable/c/ebc5c630457783d17d0c438b0ad70b232a64a82f
- https://git.kernel.org/stable/c/f2aeb7306a898e1cbd03963d376f4b6656ca2b55
- https://git.kernel.org/stable/c/099502ca410922b56353ccef2749bc0de669da78
- https://git.kernel.org/stable/c/3134bdf7356ed952dcecb480861d2afcc1e40492
- https://git.kernel.org/stable/c/3ba12c2afd933fc1bf800f6d3f6c7ec8f602ce56
- https://git.kernel.org/stable/c/6e8f1c21174f9482033bbb59f13ce1a8cbe843c3
Get alerted when CVE-2024-41044 or the next vulnerability affects your stack