What’s Vulnerable › Vulnerabilities
CVE-2024-41061: drm/amd/display: Fix array-index-out-of-bounds in dml2/FCLKChangeSupport
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-29 · updated 2026-06-17
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amd/display: Fix array-index-out-of-bounds in dml2/FCLKChangeSupport [Why] Potential out of bounds access in dml2_calculate_rq_and_dlg_params() because the value of out_lowest_state_idx used as an index for FCLKChangeSupport array can be greater than 1. [How] Currently dml2 core specifies identical values for all FCLKChangeSupport elements. Always use index 0 in the condition to avoid out of bounds access.
Affected products
- Linux kernel: from 6.7 before 6.9.11 — fixed in 6.9.11
How to fix
Upgrade to a fixed version: Linux kernel 6.9.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0ad4b4a2f6357c45fbe444ead1a929a0b4017d03
- https://git.kernel.org/stable/c/94166fe12543fbef122ca2d093e794ea41073a85
- https://git.kernel.org/stable/c/0ad4b4a2f6357c45fbe444ead1a929a0b4017d03
- https://git.kernel.org/stable/c/94166fe12543fbef122ca2d093e794ea41073a85
Get alerted when CVE-2024-41061 or the next vulnerability affects your stack