What’s Vulnerable › Vulnerabilities
CVE-2024-4107: Elementor Website Builder Pro <= 3.21.0 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Elementor Website Builder – More than Just a Page Builder Pro plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the several parameters in versions up to, and including, 3.21.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Elementor Website Builder: before 3.21.1 — fixed in 3.21.1
How to fix
Upgrade to a fixed version: Elementor Website Builder 3.21.1. Check the vendor advisory for mitigations.
References
- https://doc.clickup.com/9011113249/d/h/8chnb91-5091/3951e6f2afbd388
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0d5d47bd-4f05-4dc7-84c1-f7bc1196ee16?source=cve
- https://doc.clickup.com/9011113249/d/h/8chnb91-5091/3951e6f2afbd388
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0d5d47bd-4f05-4dc7-84c1-f7bc1196ee16?source=cve
Get alerted when CVE-2024-4107 or the next vulnerability affects your stack