What’s Vulnerable › Vulnerabilities
CVE-2024-41077: null_blk: fix validation of block size
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-29 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: null_blk: fix validation of block size Block size should be between 512 and PAGE_SIZE and be a power of 2. The current check does not validate this, so update the check. Without this patch, null_blk would Oops due to a null pointer deref when loaded with bs=1536 [1]. [axboe: remove unnecessary braces and != 0 check]
Affected products
- Linux kernel: before 5.10.223; from 5.11 before 5.15.164; from 5.16 before 6.1.101; from 6.2 before 6.6.42; from 6.7 before 6.9.11; 6.10-rc1, 6.10-rc2 — fixed in 5.10.223, 5.15.164, 6.1.101, 6.6.42, 6.9.11
How to fix
Upgrade to a fixed version: Linux kernel 5.10.223, 5.15.164, 6.1.101, 6.6.42. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/08f03186b96e25e3154916a2e70732557c770ea7
- https://git.kernel.org/stable/c/2772ed2fc075eef7df3789906fc9dae01e4e132e
- https://git.kernel.org/stable/c/9625afe1dd4a158a14bb50f81af9e2dac634c0b1
- https://git.kernel.org/stable/c/9b873bdaae64bddade9d8c6df23c8a31948d47d0
- https://git.kernel.org/stable/c/c462ecd659b5fce731f1d592285832fd6ad54053
- https://git.kernel.org/stable/c/f92409a9da02f27d05d713bff5f865e386cef9b3
- https://git.kernel.org/stable/c/08f03186b96e25e3154916a2e70732557c770ea7
- https://git.kernel.org/stable/c/2772ed2fc075eef7df3789906fc9dae01e4e132e
- https://git.kernel.org/stable/c/9625afe1dd4a158a14bb50f81af9e2dac634c0b1
- https://git.kernel.org/stable/c/9b873bdaae64bddade9d8c6df23c8a31948d47d0
- https://git.kernel.org/stable/c/c462ecd659b5fce731f1d592285832fd6ad54053
- https://git.kernel.org/stable/c/f92409a9da02f27d05d713bff5f865e386cef9b3
Get alerted when CVE-2024-41077 or the next vulnerability affects your stack