What’s Vulnerable › Vulnerabilities
CVE-2024-41086: bcachefs: Fix sb_field_downgrade validation
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-29 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: bcachefs: Fix sb_field_downgrade validation - bch2_sb_downgrade_validate() wasn't checking for a downgrade entry extending past the end of the superblock section - for_each_downgrade_entry() is used in to_text() and needs to work on malformed input; it also was missing a check for a field extending past the end of the section
Affected products
- Linux kernel: from 6.7.1 before 6.9.8; 6.7 — fixed in 6.9.8
How to fix
Upgrade to a fixed version: Linux kernel 6.9.8. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/692aa7a54b2b28d59f24b3bf8250837805484b99
- https://git.kernel.org/stable/c/bf920ed92ef24dcd6970c88881cd4700b3acf05b
- https://git.kernel.org/stable/c/692aa7a54b2b28d59f24b3bf8250837805484b99
- https://git.kernel.org/stable/c/bf920ed92ef24dcd6970c88881cd4700b3acf05b
Get alerted when CVE-2024-41086 or the next vulnerability affects your stack