What’s Vulnerable › Vulnerabilities
CVE-2024-41088: can: mcp251xfd: fix infinite loop when xmit fails
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-29 · updated 2026-06-17
- Weakness: CWE-835
Description
In the Linux kernel, the following vulnerability has been resolved: can: mcp251xfd: fix infinite loop when xmit fails When the mcp251xfd_start_xmit() function fails, the driver stops processing messages, and the interrupt routine does not return, running indefinitely even after killing the running application. Error messages: [ 441.298819] mcp251xfd spi2.0 can0: ERROR in mcp251xfd_start_xmit: -16 [ 441.306498] mcp251xfd spi2.0 can0: Transmit Event FIFO buffer not empty. (seq=0x000017c7, tef_tail=0x000017cf, tef_head=0x000017d0, tx_head=0x000017d3). ... and repeat forever. The issue can be triggered when multiple devices share the same SPI interface. And there is concurrent access to the bus. The problem occurs because tx_ring->head increments even if mcp251xfd_start_xmit() fails. Consequently, the driver skips one TX package while still expecting a response in mcp251xfd_handle_tefif_one(). Resolve the issue by starting a workqueue to write the tx obj synchronously if err = -EBUSY. In case of another error, decrement tx_ring->head, remove skb from the echo stack, and drop the message. [mkl: use more imperative wording in patch description]
Affected products
- Linux kernel: from 5.10 before 6.1.97; from 6.2 before 6.6.37; from 6.7 before 6.9.8 — fixed in 6.1.97, 6.6.37, 6.9.8
How to fix
Upgrade to a fixed version: Linux kernel 6.1.97, 6.6.37, 6.9.8. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3e72558c1711d524e3150103739ddd06650e291b
- https://git.kernel.org/stable/c/6c6b4afa59c2fb4d1759235f866d8caed2aa4729
- https://git.kernel.org/stable/c/d8fb63e46c884c898a38f061c2330f7729e75510
- https://git.kernel.org/stable/c/f926c022ebaabf7963bebf89a97201d66978a025
- https://git.kernel.org/stable/c/3e72558c1711d524e3150103739ddd06650e291b
- https://git.kernel.org/stable/c/6c6b4afa59c2fb4d1759235f866d8caed2aa4729
- https://git.kernel.org/stable/c/d8fb63e46c884c898a38f061c2330f7729e75510
- https://git.kernel.org/stable/c/f926c022ebaabf7963bebf89a97201d66978a025
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-41088 or the next vulnerability affects your stack