What’s Vulnerable › Vulnerabilities
CVE-2024-41095: drm/nouveau/dispnv04: fix null pointer dereference in nv17_tv_get_ld_modes
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-29 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: drm/nouveau/dispnv04: fix null pointer dereference in nv17_tv_get_ld_modes In nv17_tv_get_ld_modes(), the return value of drm_mode_duplicate() is assigned to mode, which will lead to a possible NULL pointer dereference on failure of drm_mode_duplicate(). Add a check to avoid npd.
Affected products
- Linux kernel: before 4.19.317; from 4.20 before 5.4.279; from 5.5 before 5.10.221; from 5.11 before 5.15.162; from 5.16 before 6.1.97; from 6.2 before 6.6.37 — fixed in 4.19.317, 5.10.221, 5.15.162, 5.4.279, 6.1.97, 6.6.37
How to fix
Upgrade to a fixed version: Linux kernel 4.19.317, 5.10.221, 5.15.162, 5.4.279. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0d17604f2e44b3df21e218fe8fb3b836d41bac49
- https://git.kernel.org/stable/c/259549b2ccf795b7f91f7b5aba47286addcfa389
- https://git.kernel.org/stable/c/66edf3fb331b6c55439b10f9862987b0916b3726
- https://git.kernel.org/stable/c/9289cd3450d1da3e271ef4b054d4d2932c41243e
- https://git.kernel.org/stable/c/bdda5072494f2a7215d94fc4124ad1949a218714
- https://git.kernel.org/stable/c/cb751e48bbcffd292090f7882b23b215111b3d72
- https://git.kernel.org/stable/c/dbd75f32252508ed6c46c3288a282c301a57ceeb
- https://git.kernel.org/stable/c/f95ed0f54b3d3faecae1140ddab854f904a6e7c8
- https://git.kernel.org/stable/c/0d17604f2e44b3df21e218fe8fb3b836d41bac49
- https://git.kernel.org/stable/c/259549b2ccf795b7f91f7b5aba47286addcfa389
- https://git.kernel.org/stable/c/66edf3fb331b6c55439b10f9862987b0916b3726
- https://git.kernel.org/stable/c/9289cd3450d1da3e271ef4b054d4d2932c41243e
Get alerted when CVE-2024-41095 or the next vulnerability affects your stack