What’s Vulnerable › Vulnerabilities
CVE-2024-41109: Pimcore vulnerable to disclosure of system and database information behind /admin firewall
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-30 · updated 2026-06-17
- Weakness: CWE-200
Description
Pimcore's Admin Classic Bundle provides a backend user interface for Pimcore. Navigating to `/admin/index/statistics` with a logged in Pimcore user exposes information about the Pimcore installation, PHP version, MYSQL version, installed bundles and all database tables and their row count in the system. This vulnerability is fixed in 1.5.2, 1.4.6, and 1.3.10.
Affected products
- pimcore admin-ui-classic-bundle: before 1.3.10; from 1.4.0 before 1.4.6; from 1.5.0 before 1.5.2 — fixed in 1.3.10, 1.4.6, 1.5.2
How to fix
Upgrade to a fixed version: pimcore admin-ui-classic-bundle 1.3.10, 1.4.6, 1.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/admin-ui-classic-bundle/blob/1.x/src/Controller/Admin/IndexController.php#L125C24-L125C40
- https://github.com/pimcore/admin-ui-classic-bundle/commit/afa10bff2f8bfe9c8af7b6b75885bc403f6984f0
- https://github.com/pimcore/admin-ui-classic-bundle/releases/tag/v1.5.2
- https://github.com/pimcore/admin-ui-classic-bundle/security/advisories/GHSA-fx6j-9pp6-ph36
- https://github.com/pimcore/admin-ui-classic-bundle/blob/1.x/src/Controller/Admin/IndexController.php#L125C24-L125C40
- https://github.com/pimcore/admin-ui-classic-bundle/commit/afa10bff2f8bfe9c8af7b6b75885bc403f6984f0
- https://github.com/pimcore/admin-ui-classic-bundle/releases/tag/v1.5.2
- https://github.com/pimcore/admin-ui-classic-bundle/security/advisories/GHSA-fx6j-9pp6-ph36
Get alerted when CVE-2024-41109 or the next vulnerability affects your stack